ccna90

پروتکل مسیریابی EIGRP

Enhanced Interior Gateway Routing Protocol: EIGRP

EIGRP is a Cisco-proprietary Hybrid routing protocol, incorporating features of both Distance-Vector and Link-State routing protocols.

EIGRP uses Diffusing Update Algorithm (DUAL) to determine the best path among all “feasible” paths. DUAL also helps ensure a loopfree routing environment.

EIGRP traffic is sent as multicast to 224.0.0.10

EIGRP routers don’t send periodic, full-table routing updates. Updates are sent when a change occurs, and include only the change.

 

 

  • عملکرد درونی EIGRP از الگوریتمی به نام dual استفاده میکند.
  • در این پروتکل، روترها routing table و آپدیت های مربوط به آن را فقط به روترهایی ارسال میکنند که دارای AS مشترک باشند.
  • EIGRP از متریک برای انتخاب بهترین مسیر استفاده میکند. هر چه عدد متریک مسیری کمتر باشد، آن مسیر بعنوان بهترین مسیر انتخاب می شود.
  • EIGRP هر 90 ثانیه یکبار جدول مسیریابی اش را آپدیت میکند.
  • EIGRP از نوع Classless است و میتوان از قابلیت های Subnetting و VLSM استفاده کرد.
  • Autonomous System: AS

EIGRP supports IP, IPX, and Appletalk routing.
EIGRP has an Administrative Distance of 90 for routes originating within the local Autonomous System.
EIGRP has an Administrative Distance of 170 for external routes coming from outside the local Autonomous System
EIGRP uses Bandwidth and Delay to calculate the metric, by default. It also supports three other parameters to calculate its metric: Reliability, Load, and MTU. They are shown as K1, K2, K3, K4 and K5. 

 

EIGRP Example scenario:

 

 

 

R1-DHCP-Server#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1-DHCP-Server(config)#router eigrp 100

R1-DHCP-Server(config-router)#network 172.16.0.0 ?
A.B.C.D EIGRP wild card bits

R1-DHCP-Server(config-router)#network 172.16.0.0
R1-DHCP-Server(config-router)#net
R1-DHCP-Server(config-router)#network 192.168.0.0
R1-DHCP-Server(config-router)#end
R1-DHCP-Server#wr mem
*Mar 1 00:25:04.283: %SYS-5-CONFIG_I: Configured from console by console
R1-DHCP-Server#wr mem
Building configuration…
[OK]
R1-DHCP-Server#
*Mar 1 00:25:34.595: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.0.2 (FastEthernet0/1) is up: new adjacency

 

 

R2(config)#router eigrp ?
<1-65535> Autonomous system number

R2(config)#router eigrp 100
R2(config-router)#network 192.168.0.0
R2(config-router)#ne
*Mar 1 00:27:26.575: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.0.1 (FastEthernet0/0) is up: new adjacency
R2(config-router)#net
R2(config-router)#network 172.17.0.0
R2(config-router)#network 192.168.1.0
R2(config-router)#end
*Mar 1 00:27:46.871: %SYS-5-CONFIG_I: Configured from console by console
R2#wr mem
Building configuration…
[OK]
R2#
*Mar 1 00:28:37.651: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.1.2 (FastEthernet1/0) is up: new adjacency
R2#

 

R3(config)#router eigrp 100
R3(config-router)#network 172.18.0.0
R3(config-router)#network 192.168.1.0
R3(config-router)#
*Mar 1 00:21:36.199: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.1.1 (FastEthernet0/0) is up: new adjacency

 

جهت آشنایی بیشتر با مفاهیم شبکه در دوره آموزشی CCNA Routing and Switching شرکت نمایید.

 

Monitoring EIGRP:

 

 

R1-DHCP-Server#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

D 172.17.0.0/16 [90/307200] via 192.168.0.2, 00:03:00, FastEthernet0/1
C 172.16.0.0/16 is directly connected, FastEthernet0/0
D 172.18.0.0/16 [90/309760] via 192.168.0.2, 00:23:09, FastEthernet0/1
C 192.168.0.0/24 is directly connected, FastEthernet0/1
D 192.168.1.0/24 [90/284160] via 192.168.0.2, 00:23:57, FastEthernet0/1
R1-DHCP-Server#

 

 

 

 

R2#
R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C 172.17.0.0/16 is directly connected, FastEthernet0/1
D 172.16.0.0/16 [90/307200] via 192.168.0.1, 00:04:43, FastEthernet0/0
D 172.18.0.0/16 [90/284160] via 192.168.1.2, 00:04:43, FastEthernet1/0
C 192.168.0.0/24 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet1/0
R2#

 

 

R3#
R3#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

D 172.17.0.0/16 [90/307200] via 192.168.1.1, 00:05:06, FastEthernet0/0
D 172.16.0.0/16 [90/332800] via 192.168.1.1, 00:25:11, FastEthernet0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/1
D 192.168.0.0/24 [90/307200] via 192.168.1.1, 00:25:11, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
R3#

 

مقدار 90 در واقع مقدار administrative distance است که همانطور که قبلا گفتیم مقدار این پارامتر برای مسیرهای EIGRP عدد 90 است. پس از علامت / هم مقدار متریک مسیر به نمایش در آمده است.

 

 

R1-DHCP-Server#
R1-DHCP-Server#show ip protocols
Routing Protocol is “eigrp 100”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is in effect
Automatic address summarization:
192.168.0.0/24 for FastEthernet0/0
172.16.0.0/16 for FastEthernet0/1
Maximum path: 4
Routing for Networks:
172.16.0.0
192.168.0.0
Routing Information Sources:
Gateway Distance Last Update
192.168.0.2 90 00:08:27
Distance: internal 90 external 170

R1-DHCP-Server#

 

 

R2#show ip protocols
Routing Protocol is “eigrp 100”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is in effect
Automatic address summarization:
192.168.1.0/24 for FastEthernet0/0, FastEthernet0/1
192.168.0.0/24 for FastEthernet1/0, FastEthernet0/1
172.17.0.0/16 for FastEthernet0/0, FastEthernet1/0
Maximum path: 4
Routing for Networks:
172.17.0.0
192.168.0.0
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
192.168.0.1 90 00:09:51
Gateway Distance Last Update
192.168.1.2 90 00:09:54
Distance: internal 90 external 170

R2#

 

 

R3#
R3#show ip protocols
Routing Protocol is “eigrp 100”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is in effect
Automatic address summarization:
192.168.1.0/24 for FastEthernet0/1
172.18.0.0/16 for FastEthernet0/0
Maximum path: 4
Routing for Networks:
172.18.0.0
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
192.168.1.1 90 00:10:00
Distance: internal 90 external 170

 

جهت آشنایی بیشتر با مفاهیم شبکه در دوره آموزشی CCNA Routing and Switching شرکت نمایید.

 

EIGRP, like OSPF, builds three separate tables:


Neighbor table – list of all neighboring routers. Neighbors must belong to the same Autonomous System
Topology table – list of all routes in the Autonomous System
Routing table – contains the best route for each known network (#Show ip route)

 

 

EIGRP Adjacency and Hello packets:

 

EIGRP forms neighbor relationships, called adjacency, with other routers in the same AS by exchanging Hello packets. After the adjacency is formed the routers share their information.

Default setting for multi-casting hello packets to the address of 224.0.0.10 is 5 seconds for LAN and 60 seconds for WAN interfaces with the speed of lower than 1.5 Mbps.

 

Changing EIGRP hello-interval for an Autonomous system:

 

 

R1-DHCP-Server#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1-DHCP-Server(config)#interface fa 0/1
R1-DHCP-Server(config-if)#ip hello-interval ?
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
R1-DHCP-Server(config-if)#ip hello-interval eigrp ?
<1-65535> Autonomous system number

R1-DHCP-Server(config-if)#ip hello-interval eigrp 100 ?
<1-65535> Seconds between hello transmissions

R1-DHCP-Server(config-if)#ip hello-interval eigrp 100 6 ?
<cr>

R1-DHCP-Server(config-if)#ip hello-interval eigrp 100 6
R1-DHCP-Server(config-if)#

 

 

EIGRP Hold Timer:

Hold Timer indicates how long a router should wait before considering a neighbor inactive. This happens when the router does not receive hello packets from a neighbor. Hold Timer is three times the hello timer is, by default.

 

R1-DHCP-Server(config-if)#ip hold-time ?
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)

R1-DHCP-Server(config-if)#ip hold-time eigrp 100 20
R1-DHCP-Server(config-if)#

 

 

There is no need for the HOLD and HELLO timers to match between routers in an AS. They can have different timers and still adjacency will form.

 

Neighbors:

 

 

R1-DHCP-Server#show ip eigrp ?
<1-65535> Autonomous System
accounting    IP-EIGRP Accounting
interfaces      IP-EIGRP interfaces
neighbors      IP-EIGRP neighbors
topology        IP-EIGRP Topology Table
traffic            IP-EIGRP Traffic Statistics
vrf                  Select a VPN Routing/Forwarding instance

 

R1-DHCP-Server#show ip eigrp neighbors

 

 

 

show ip eigrp interfaces

 

 

Show ip route:

 

 

Show ip eigrp topology:

 

 

 

جهت آشنایی بیشتر با مفاهیم شبکه در دوره آموزشی CCNA Routing and Switching شرکت نمایید.

 

 آکادمی تخصصی شبکه و امنیت. ITperfection

جهت دسترسی به اطلاعات بیشتر میتوانید به صفحه بلاگ آیتی پرفکشن مراجعه کنید.

آیتی پرفکشن تهیه کننده و ارایه دهنده دوره های تخصصی شبکه و امنیت میباشد. از دانشجویان عزیز دعوت میشود جهت شرکت در دوره های آموزشی شبکه و امنیت به صفحه دوره های آموزشی مراجعه کنند.

جهت شرکت در دوره های آموزشی سیسکو به صفحه دوره سیسکو مراجعه کنید.

0 پاسخ به "پروتکل مسیریابی EIGRP"

    ارسال یک پیغام

    نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

    5 × دو =

    کپی رایت آکادمی ITperfection.