ccna90

آشنایی با مفهوم و کارکرد DHCP Server

DHCP Service Concepts:

در شبکه به هر دیوایسی که بتواند تنظیمات IP address را دریافت کند Host گفته میشود. هر Host برای آنکه بتواند در یک شبکه به فعالیت بپردازد، به 4 تنظیم نیاز دارد:

 

  • IP address
  • Subnet Mask
  • Default Gateway Address
  • DNS server address

 

جهت آشنایی بیشتر با مفاهیم شبکه در دوره آموزشی CCNA Routing and Switching شرکت نمایید.

 

وقتی یک host که تنظیم دریافت IP آن روی حالت خودکار است وارد محیط شبکه می شود، برای اینکه بتواند فعالیت کند به تنظیمات IP نیاز دارد، پس سعی میکند تنظیمات فوق را دریافت کند. اینجا مکانیزم DORA رخ میدهد.

 

DHCP Discover

DHCP Offer

DHCP Request

DHCP Acknowledge

 

DHCP Relay Agent

 

همانطور که دیدید مراحل DORA بشدت متکی بر مکانیزم بسته های broadcast است. در بیشتر شبکه ها بیشتر از یک subnet داریم و طبعا بین subnet ها هم روتر قرار دارد. یکی از وظایف اولیه و ذاتی روترها هم که drop کردن بسته های broadcast است. 

روی هر روتر ، اینترفیس مرتبط با سابنت های A و C وکیل و وصی DHCP سرور شبکه شود. در هر سابنت بسته های DORA کماکان بصورت broadcast رد و بدل میشود. کار DHCP relay agent هر سابنت اینست که این پیغامهای broadcast را دریافت کرده، آنرا بصورت پیغام unicast بسوی DHCP Server بفرستد.

 

 

DHCP Configuration on a router example:

 

 

 

R1-DHCP-Server#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1-DHCP-Server(config)#service dhcp
R1-DHCP-Server(config)#ip dhcp pool ITPerfection-HQ
R1-DHCP-Server(dhcp-config)#network 172.16.0.0 255.255.0.0
R1-DHCP-Server(dhcp-config)#domain-name ITPerfection.local

R1-DHCP-Server(dhcp-config)#dns-server 8.8.8.8 4.2.2.4 ?

R1-DHCP-Server(dhcp-config)#default-router 172.16.0.1
R1-DHCP-Server(dhcp-config)#lease ?
<0-365> Days
infinite Infinite lease

 

R1-DHCP-Server(dhcp-config)#lease 2 0
R1-DHCP-Server(dhcp-config)#exit
R1-DHCP-Server(config)#ip dhcp excluded-address ?
A.B.C.D Low IP address

R1-DHCP-Server(config)#ip dhcp excluded-address 172.16.0.1 ?
A.B.C.D High IP address
<cr>

R1-DHCP-Server(config)#ip dhcp excluded-address 172.16.0.1 172.16.0.20

 

 

DHCP settings will look like the following in the Show run command:

 

ip dhcp excluded-address 172.16.0.1 172.16.0.20

!

ip dhcp pool ITPerfection-HQ

network 172.16.0.0 255.255.0.0

domain-name ITPerfection.local

dns-server 8.8.8.8 4.2.2.4

default-router 172.16.0.1

lease 2

!

!

 

How to configure a router port to receive an ip address form a DHCP server:

PC3-DHCP-Client#conf t
Enter configuration commands, one per line. End with CNTL/Z.
PC3-DHCP-Client(config)#inter fa 0/0
PC3-DHCP-Client(config-if)#ip address ?

A.B.C.D IP address
dhcp IP Address negotiated via DHCP
pool IP Address autoconfigured from a local DHCP pool

 

PC3-DHCP-Client(config-if)#ip address dhcp
*Mar 1 00:36:33.171: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0 assigned DHCP address 172.16.0.21, mask 255.255.0.0, hostname PC3-DHCP-Client

 

جهت آشنایی بیشتر با مفاهیم شبکه در دوره آموزشی CCNA Routing and Switching شرکت نمایید.

 

Show IP DHCP server statistics:

 

R1-DHCP-Server#show ip dhcp server statistics
Memory usage 24031
Address pools 1
Database agents 0
Automatic bindings 1
Manual bindings 0
Expired bindings 0
Malformed messages 0
Secure arp entries 0

Message Received
BOOTREQUEST 0
DHCPDISCOVER 1
DHCPREQUEST 1
DHCPDECLINE 0
DHCPRELEASE 0
DHCPINFORM 0

Message Sent
BOOTREPLY 0
DHCPOFFER 1
DHCPACK 1
DHCPNAK 0

 

 

Show IP DHCP pool:

 

R1-DHCP-Server#show ip dhcp pool

Pool ITPerfection-HQ :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 65534
Leased addresses : 1
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
172.16.0.22 172.16.0.1 – 172.16.255.254 1

 

Show IP DHCP binding:

 

 

 

 

 

 

 

 

 

جهت آشنایی بیشتر با مفاهیم شبکه در دوره آموزشی CCNA Routing and Switching شرکت نمایید.

 

 آکادمی تخصصی شبکه و امنیت. ITperfection

جهت دسترسی به اطلاعات بیشتر میتوانید به صفحه بلاگ آیتی پرفکشن مراجعه کنید.

آیتی پرفکشن تهیه کننده و ارایه دهنده دوره های تخصصی شبکه و امنیت میباشد. از دانشجویان عزیز دعوت میشود جهت شرکت در دوره های آموزشی شبکه و امنیت به صفحه دوره های آموزشی مراجعه کنند.

جهت شرکت در دوره های آموزشی سیسکو به صفحه دوره سیسکو مراجعه کنید.

0 پاسخ به "آشنایی با مفهوم و کارکرد DHCP Server"

    ارسال یک پیغام

    نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

    12 − 10 =

    کپی رایت آکادمی ITperfection.